Сивый Кобыл (homya4ok) wrote in ua_sysadmin,
Сивый Кобыл
homya4ok
ua_sysadmin

Cisco Router как L2TP клиент

Задача: настроить Cisco Router как L2TP клиент с шифрованием L2TP-тоннеля с помощю IPSec.

Адрес VPN-сервера 10.1.1.1
Наш адрес 10.1.1.57

l2tp-class DEFAULT-L2TP-CLASS

pseudowire-class PW-L2TP-FA00
encapsulation l2tpv2
protocol l2tpv2 DEFAULT-L2TP-CLASS
ip local interface FastEthernet0/0

crypto isakmp policy 100
hash md5
authentication pre-share

crypto isakmp key pre-shared-key address 0.0.0.0 0.0.0.0

crypto ipsec transform-set L2TP esp-3des esp-md5-hmac
mode transport

crypto map L2TP 150 ipsec-isakmp
set peer 10.1.1.1
set transform-set L2TP
match address L2TP

interface FastEthernet0/0
ip address 10.1.1.57 255.255.255.0
crypto map L2TP

interface Virtual-PPP1
ip address negotiated
ppp authentication ms-chap-v2 callin
ppp chap hostname test
ppp chap password test
pseudowire 10.1.1.1 10 pw-class PW-L2TP-FA00

ip access-list extended L2TP
permit udp host 10.1.1.57 eq 1701 host 10.1.1.1 eq 1701
Tags: cisco, ipsec, l2tp, l2tp client
Subscribe

  • Cisco: MPLS, Traffic Engineering и Class-Based Tunnel Selection

    Делая лабу на динамипсе, напоролся на грабли - не работает Class-Based Tunnel Selection. Делаю всё по цисковской документации, а включаешь - не…

  • Cisco Router as PPTP client

    Работает только после ввода скрытой комманды service internal Вот конфиг service internal ! THE MOST IMPORTANT COMMAND !!! ! no ip…

  • Cisco router, PPTP, L2TP+IPSec

    Задача - настроить доступ в локальную сеть по протоколам PPTP и L2TP с шифрованием IPSec с предварительным ключём (pre-shared key). Пользователи…

  • Post a new comment

    Error

    default userpic

    Your IP address will be recorded 

    When you submit the form an invisible reCAPTCHA check will be performed.
    You must follow the Privacy Policy and Google Terms of use.
  • 0 comments